{{{#!html 데비안 초간단 설치 노트
}}} [[TableOfContents]] 데비안은 아래 사이트에서 볼 수 있듯이 여러 릴리스가 있지만[[br]] http://www.debian.org/releases/ 공부겸 데스크탑 용도로는 testing(squeeze)이 좋기 때문에 testing을 기준으로 설명합니다.[[br]] (데비안은 testing이 testing이 아닙니다.) 참고:[[br]] 지금 lenny가 testing에서 stable로 옮긴지 얼마 안 되었기 때문에 [[br]] 취향에 따라 stable(lenny),testing(squeeze)선택하세요. 개인적 견해로[[br]] 우분투 == 데비안 unstable(sid) or testing(squeeze)[[br]] 우분투 beta == 데비안 experimental unstable,testing의 관계에 대해 알 수 있는 글[[br]] http://cwryu.textcube.com/30 [[br]] http://cwryu.tistory.com/30 ---- 현재(2009년 12월 13일)[[br]] testing(squeeze) 설치시 저장소를 미국 기본으로 해야 정상적으로 설치됩니다.[[br]] 그놈 패키지들이 제대로 설치 안 되서 그놈이 이상해 지거나 최악의 경우 콘솔로 부팅되는 경우가 있음[[br]] (저장소를 한국(다음),일본으로 설정하고 테스트해 보았는데 전부 실패하였음)[[br]] == 설치 == === 다운로드 === 데비안 CD 첫번째장만 다운로드 받습니다.[[br]] 인터넷이 안 되는 특수한 곳에서 사용하지 않는한 DVD 버전 받을 필요가 없고[[br]] 예전에 디스크 스캐닝 버그로 두번째장까지 필요했으나 해결되었습니다. CD 버전보다 용량이 작은 netinst 버전을 설치하셔도 되지만[[br]] 예기치 않은 네트워크 장애(하드웨어 포함)가 발생하면 설치후 콘솔화면만 나오므로[[br]] 처음 설치하시는 분께는 권장하지 않습니다. * stable(lenny) * http://www.debian.org/releases/stable/debian-installer/ * 한국미러 ftp://ftp.kr.debian.org/debian-cd/ * testing(squeeze) * http://www.debian.org/devel/debian-installer/ * http://cdimage.debian.org/cdimage/squeeze_di_beta2/i386/ * http://cdimage.debian.org/cdimage/weekly-builds/ - {{{BitTorrent}}}사용 추천합니다. === 부팅 === 첫번째장을 시디롬에 넣고 부팅후 메뉴가 나오면 {{{ Install Graphical Install }}} 둘 중 하나 선택 === 설치 진행 === * Choose language Korean - 한국어 (k누르고 아래 화살표키(↓) 누름 Korean - 한국어로 곧바로 감) 주의! "Kazakh" 선택하지 말 것!!! * 키보드 배치 선택 미국 영어 * 네트워크 설정 호스트 이름: debian (적당히 아무거나)[[br]] 도메인 이름: debian.at.home (적당히 full qualified hostname 되도록)[[br]] (도메인 이름을 설정 안 하면 부팅할 때 Starting MTA 에서 멈추는 현상 있음) * 파티션 설정 * 사용자 및 암호 설정 (잘 적어 두세요.) * 패키지 관리자 설정 다른 CD나 DVD를 검사하시겠습니까? 아니오[[br]] 네트워크 미러 사이트를 사용하시겠습니까? 예[[br]] 데비안 아카이브 미러 국가[[br]] 대한민국 미러가 잘 안되는 경우가 많으므로 미국 사용[[br]] (나중에 추가 설정 및 수정 가능함) * 프록시 서버 설정: 엔터 * popularity-contest 설정: 예 시스템에 아무런 해가 없고 데비안을 더 좋게 만드는데 쓰이므로...[[br]] 더 좋게되면 우린 더 좋은 데비안을 쓰게 되는 것임 winwin :)[[br]] (나중에 dpkg-reconfigure popularity-contest 로 변경 할 수 있음) * 소프트웨어 선택 데스크탑 환경, 표준 시스템[[br]] (나머지는 나중에 필요에 따라 설치 할 수 있음)[[br]] tab눌러서 계속 버튼 반전 되면 엔터 * 하드 디스크에 GRUB 부트로더 설치 마스터 부트 레코드에 GRUB 부트로더를 설치하시겠습니까? 예 * 설치 마치기 CD빼고 계속 버튼 누름 {o} '''squeeze alpha1'''[[br]] squeeze alpha1 설치 중에 바탕화면이 빨간색으로 변하고 아래 내용이 나오면[[br]] 잘 읽어 보고 설정하세요. 대부분 기본값으로 하면 문제없습니다.[[br]] {{{ linux-base 설정 중입니다. ... Update diskdevice IDs is system configuration }}} == 기본 설정 == 처음 설치후 데비안으로 부팅하면 화면 치우침이 생길 수 있는데[[br]] 아래 설명을 참고해서 그래픽 드라이버를 설치하면 됩니다. 설치를 마치고 처음 데비안이 부팅되면 아래 진행 ---- {*} '''wheezy/jessie'''[[br]] 현재(2014년 2월 12일)[[br]] wheezy/jessie 설치 후 별 특이한 점이 없는데도 네트워크(wired)가 안 되고 아래 증상이 있으신 분은 {{{ # /etc/init.d/network-manager stop # dhclient -v eth0 . .. ... DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 2 No DHCPOFFERS received. No working leases in persistent database - sleeping. }}} 아래를 시도해 보세요. {{{ # vi /etc/default/grub # 아래 부분 수정(acpi와 헷갈리지 말 것!) GRUB_CMDLINE_LINUX="noapic" # update-grub 재부팅 }}} === 시냅틱 꾸러미 관리자 === 그놈 메뉴에서 시스템 -> 관리 -> 시냅틱 꾸러미 관리자 시냅틱 메뉴 설정 -> 저장소 * Debian Software 에 나온 체크 박스 전부 체크 * Third-Party Software 에서 cdrom 전부 체크해제[[br]] (시냅틱에서 패키지 설치할 때마다 CD넣으라고 나와서 귀찮으므로...) 설정 -> 기본 설정 일반탭에서 메인 창에 꾸러미 정보 표시 체크 새로고침 버튼 눌러서 업데이트 최신 버전으로 유지하기 위해 "모든 업그레이드 표시"버튼 누르고 적용 버튼[[br]] (weekly snapshot으로 설치했을 경우등 최신 상태이면 안해도 됨) 자주 사용하게 되므로 그놈 메뉴의 시냅틱 꾸러미 관리자에서 마우스 오르쪽 버튼을 누르고[[br]] "이 실행 아이콘을 패널에 더하기" 눌러서 패널에 추가하세요. === 노틸러스 모양 수정 === 자신의 폴더를 더블 클릭하면 MS윈도우에서 탐색기같은 노틸러스가 실행되는데[[br]] 처음 상태로는 사용이 불편하기 때문에 편집 -> 기본 설정[[br]] 보기탭에서[[br]] 다음을 이용하여 새 폴더 보기 : 목록보기[[br]] 숨김/백업 파일 보기 : 체크[[br]] 동작탭에서[[br]] 항상 찾아보기 창으로 열기 : 체크 다시 실행해 보면 MS탐색기와 비슷한 모양으로 실행되고[[br]] 만약 왼쪽에 트리를 보고 싶으면 왼쪽 패널에서 위치버튼을 눌러 트리로 바꾸면 됩니다. {o} '''squeeze alpha1'''[[br]] squeeze alpha1에서 위 방법이 안 되면 설정 편집기(gconf-editor)사용하는 아래 방법 시도해 보세요.[[br]] http://kldp.org/node/90870 === 루트 노틸러스 만들기 === 시스템 설정같은 것은 루트 권한이 필요한데 처음 부터 콘솔 터미널에서 하는 것은 엄청 어렵고 힘이 들므로[[br]] 위쪽 패널 공백에 오른쪽 마우스 버튼을 누르고 "패널에 더하기" 선택[[br]] "사용자 지정 프로그램 실행 아이콘"선택 후 더하기 버튼 클릭 실행 아이콘 만들기 대화상자가 나오면[[br]] 이름에 root nautilus[[br]] 명령어에 gksu nautilus[[br]] 입력후 확인 버튼 클릭 방금 만든 루트 노틸러스를 실행해서 위 노틸러스 모양 수정에서처럼 노틸러스 설정을 변경해줌[[br]] (이해하기 힘든 부분일 수도 있으나 root nautilus는 루트권한으로 실행되는 것이기 때문에 일반 사용자로 실행한 노틸러스와 설정을 공유하지 않습니다.)[[br]] 이제 설정 변경이 필요할때 마다 root nautilus 를 사용하면 됩니다. 참고:[[br]] 자신의 계정에 있는 파일은 시스템 폴더에 복사하거나 옮길 때는 루트 노틸러스 내부에서 해야합니다.[[br]] 예를 들어 바탕화면의 파일을 복사하고 루트 노틸러스에 붙여넣기를 하면 권한 문제로 안되는 경우가 있으니[[br]] (경고 메시지조차 않나오는 경우가 있음)[[br]] 바탕화면이라면 루트 노틸러스의 파일 시스템 노드에서 "/home/자신의 계정/Desktop/원하는 파일" 이렇게 접근해서 사용해야 합니다. {*} '''squeeze beta2'''[[br]] 이전 버전에서는 루트 노틸러스 휴지통을 비우기 위해 루트 노틸러스로 "/root/.local/share/Trash/" 폴더에 들어가면[[br]] 리스트 뷰 상단에 휴지통 비우기 버튼이 나타나서 편하게 삭제할 수 있었는데[[br]] squeeze beta2 에서는 버튼이 안 나타나는 관계로 실행 아이콘 만들기로[[br]] 이름에 clear root trash[[br]] 명령어에 gksu "rm -rf /root/.local/share/Trash/"[[br]] 이렇게 만드는 것이 최선인 듯. === 루트 터미널 패널에 추가 === 그놈 메뉴에서[[br]] 프로그램->보조 프로그램->루트 터미널[[br]] 마우스 오른쪽 버튼 클릭후 이 실행 아이콘을 패널에 더하기 눌러서 패널에 추가해 줍니다. === sudo 설정 === 1)루트 터미널에서 {{{ # visudo }}} 안전을 위해 {{{# %sudo ALL=NOPASSWD: ALL}}} 을 언코멘트하기 보다 {{{ %sudo ALL=(ALL)ALL }}} 를 추가합니다. {{{RC1}}}에서 visudo 기본 편집기가 nano 인데 실행 후 화면 아래부분의 단축키를 참고해서[[br]] Ctrl + o (저장하기)후 아래처럼 나오면[[br]] {{{ File Name to Write: /etc/sudoers.tmp }}} 아래처럼 수정 {{{ File Name to Write: /etc/sudoers File exists, OVERWRITE ? y }}} Ctrl + x (종료하기) 2) 자신의 계정을 sudo 그룹에 추가 루트 터미널에서 {{{ # usermod -a -G sudo 자신의 계정 }}} 아래 명령어로 그룹이 잘 추가 되었는지 검사 {{{ # groups 자신의 계정 }}} === 자동 로그인 === 집에서 혼자 데스크탑 용도로 사용할 경우 편의를 위해[[br]] 그놈 메뉴[[br]] 시스템 -> 관리 -> 로그인창[[br]] 보안탭 자동 로그인 사용 체크 , 자신의 계정 선택 === root 암호 입력 없이 shutdown === 루트 터미널에서 {{{ # usermod -a -G powerdev 자신의 계정 }}} === GRUB 부팅 기본 순서 변경 및 timeout 없애기 === 위에서 만든 root nautilus 실행[[br]] (주의하세요! 루트권한으로 시스템 설정파일을 수정하는 것인 만큼...) '''윈도우가 기본이 되길 원할 경우'''[[br]] 보통 MS윈도우와 듀얼 부팅한다면 default가 0이면 데비안, 3이면 MS윈도우입니다.[[br]] (언뜻 생각해서 4일 것 같지만 그러면 한바퀴 돌아서 0과 같아짐)[[br]] {o} '''lenny'''[[br]] /boot/grub/menu.lst {{{ default 3 }}} {*} '''squeeze beta2'''[[br]] /etc/default/grub {{{ GRUB_DEFAULT=2 }}} 루트 터미널에서 아래 실행 {{{ # update-grub }}} '''grub에서 timeout되는 것이 싫다면'''[[br]] {o} '''lenny''' /boot/grub/menu.lst 아래 주석 처리 {{{ #timeout 5 }}} {*} '''squeeze beta2''' /etc/default/grub {{{ GRUB_TIMEOUT=-1 }}} 루트 터미널에서 아래 실행 {{{ # update-grub }}} {o} '''squeeze alpha1'''[[br]] grub2(squeeze alpha1) 관련[[br]] [리눅스] 데비안 grub-pc 설치 후 MS-Windows 엔트리 추가 방법[[br]] http://blog.daum.net/debianizer/16995186 === 그래픽 카드 드라이버 설치 === * NVidia 1) 시냅틱에서 nvidia-glx, nvidia-xconfig 설치[[br]] (구형 그래픽카드는 nvidia-glx-legacy-96xx 설치, nvidia-xconfig가 맞는 버전이 없다면 173.14.09-1 버전 설치해도 됨) 2) 루트 터미널에서 {{{ # nvidia-xconfig }}} 3) 리부팅 참고:[[br]] 위 기본 설정의 시냅틱 설정 부분에서 Debian Software 체크 박스 전부 체크하라고 한 것 해주어야 함[[br]] 그렇지 않으면 저장소에 non-free가 포함이 안되서 nvidia 그래픽카드 드라이버가 안나타남 * 참고 링크 [http://www.ubuntu.or.kr/viewtopic.php?p=51784#p51784 nvidia 드라이버 640x480문제] * ATI 0) gdm or kdm 서비스를 종료시킨다( Xwindow 종료 ) {{{ X윈도우 모드에서 Ctrl + Alt + F1키를 누른다. root로 로그인한다. # /etc/init.d/gdm stop }}} 1) 기존 드라이버가 있으면 제거한다. 제거할 목록 : fglrx-driver, fglrx-glx, fglrx-control, fglrx-modules-2.6-686, fglrx-modules-2.6-486 {{{ # rmmod fglx # apt-get remove --purge fglrx-driver fglrx-glx fglrx-control fglrx-modules-2.6-686 }}} 2) module-assistant fglrx-kernel-src fglrx-driver fglrx-glx fglrx-control modconf패키지 설치 및 설치 {{{ # apt-get install module-assistant fglrx-kernel-src fglrx-driver fglrx-glx fglrx-control modconf # m-a prepare # m-a a-i fglrx # aticonfig --initial }}} 3) fglx 모듈을 올린다. {{{ # modconf (modconf 를 실행해서 Page Down키로 맨하단메뉴를 보면 misc가 있는데 그곳에 들어가면 fglx 모듈이 있다. 이것을 선택) }}} 4) Xwindow 시작 {{{ # /etc/init.d/gdm start }}} 5) 작동실험 X윈도우에서 아래명령을 실행해서 기어 돌아가는 영상이 나오면 성공. {{{ # fgl_glxgears }}} 6) 만약 위의 명령어를 실행했는데도 되지 않으면 루드 터미널, 혹은 루트로 로그인후 {{{ # aticonfig --initial # aticonfig --acpi-services=off }}} 로그인 or 리부팅한다. * 참고 링크 [http://kldp.org/node/103295 ATI HD4650 드라이브 및 페도라 설치시 문제] * 참고 링크 [http://forums.debian.net/viewtopic.php?t=37928&sid=8d0de8f9cf7931ed3f08dc23705f8466 Post subject: (Video) ATI 3650 HD] === Disk Manager 설치 === 리눅스에서는 MS윈도우처럼 자동으로 모든 하드디스크가 파일 매니저에 보이는 것이 아니라[[br]] 각각 마운트하는 것이 필요한데 그 관리를 편리하게 해주는 도구가 Disk Manager 입니다. 시냅틱에서 Disk Manager 설치[[br]] 만약 ntfs 하드디스크를 사용한다면[[br]] 시스템 -> 관리 -> Disk Manager[[br]] Enable write support 체크하세요.[[br]] (ntfs-3g 드라이버를 사용하기 위함임) {o} '''lenny'''[[br]] disk-manager를 터미널에서 실행해보면[[br]] python-notify 패키지가 없어서 사용불능으로 한다고 하니 시냅틱에서 검색후 설치해줌[[br]] {*} '''squeeze'''[[br]] hal 패키지 필요 === 사운드 효과 === 시냅틱에서 pulse-audio, gnome-audio 설치후[[br]] 시스템 -> 기본 설정 -> 소리[[br]] 소리탭에서 두개 체크 박스 체크해줌 === 글꼴 설정 === 아래 참고해서 글꼴 설정 * 리눅스(우분투)에서 굴림 글꼴(고정폭 포함) 설정하기 http://kldp.org/node/92122 * 공개 폰트 자동 다운 설치 스크립트 http://kldp.org/node/97976 참고:[[br]] 네이버 나눔 사용한다면[[br]] 시스템 -> 기본 설정 -> 모양새[[br]] 글꼴탭에서 아래 자세히 버튼 누르고 힌팅 충분히 선택 만약 make등 기본적인 빌드 도구가 설치 안되어 있다면 build-essential 패키지 설치 권장 === 스크린샷 단축키 바꾸기 === 백스페이스를 누른 다는 것이 Print키를 눌러 스크린샷되는 것이 불편하기 때문에[[br]] 시스템 -> 기본 설정 -> 키보드 바로가기 -> 데스크탑 -> 스크린샷 에서[[br]] 단축키를 Ctrl+Print로 변경 === 키보드 설정 === 1) /etc/X11/xorg.conf에서 아래 참고해서 {{{XkbModel}}},{{{XkbLayout}}} 수정하거나 추가해 줌 {{{ Section "InputDevice" Identifier "Keyboard0" #다를 수 있음 Driver "kbd" Option "XkbModel" "kr106" Option "XkbLayout" "kr" EndSection }}} 2) 그놈 메뉴에서[[br]] 시스템 -> 기본 설정 -> 키보드[[br]] 키배치 탭에서 키보드 모델 "한글 106"로 바꿔줌[[br]] 키배치에서 추가 버튼 누르고 "대한민국"키배치 추가해 주고 "미국"은 제거 === xorg.conf 설정 === 부팅할때 nvidia로고 나오는 것이 싫으신 분은 Section "Device"에 {{{ Option "NoLogo" }}} 추가 Section "Screen"에 아래 추가해 줌 {{{ Option "metamodes" "1280x1024_60 +0+0; 1152x864 +0+0; 1024x768_60 +0+0; 832x624 +0+0; 800x600_60 +0+0; 640x480 +0+0" SubSection "Display" Depth 24 Modes "1280x1024" "1024x768" "800x600" "640x480" EndSubSection }}} === USB FDD 문제 임시 해결방법 === console 명령어로는 마운트가 되는데 nautilus에서 마운트가 안되고[[br]] Unable to mount media.[[br]] There is probably no media in the drive.[[br]] 메세지가 나오면 /etc/udev/rules.d/60-persistent-storage.rules 파일에[[br]] (참고: USB FDD 가 /dev/sdb 입니다.) {{{ KERNEL=="sd[a-z]", ATTRS{removable}=="1", \ GOTO="persistent_storage_end" }}} 추가하고 아래 명령 실행 {{{ # /etc/init.d/udev restart }}} === bash 설정 === 사용하고 싶으신 분만 노틸러스의 내 폴더에서[[br]] /home/자신의 계정/.bashrc {{{ alias ll='ls -l' }}} 주석 해제 === Network service discovery disabled 메세지 문제 === {{{ Network service discovery disabled Your current network has a .local domain, which is not recommended and incompatible with the Avahi network service discovery. The service has been disabled. }}} 위와 같은 메세지가 나온다면 루트 노틸러스로[[br]] /etc/default/avahi-daemon 파일을 아래처럼 수정 {{{ AVAHI_DAEMON_DETECT_LOCAL=0 }}} === 네트워크 아이콘(nm-applet) X로 표시 되는 문제 === {o} '''squeeze alpha1'''[[br]] {{{/etc/NetworkManager/nm-system-settings.conf}}} 파일에서 아래 부분 수정 {{{ managed=true }}} == 응용 설정 == === Compiz Fusion === 위에서 처럼 그래픽 드라이버가 설치되어 있어야함[[br]] ==== 공식 저장소 것 ==== 공식 저장소에 Compiz가 추가되어 있으므로 아래 사이트 참고[[br]] http://wiki.debian.org/Compiz ==== 예전 방법 ==== 이것이 조금 더 최신 버전을 설치할 수 있음[[br]] 1) 소스리스트 추가[[br]] 루트 터미널에서 저장소 키 등록 {{{ # wget http://download.tuxfamily.org/shames/A42A6CF5.gpg -O- | apt-key add - }}} /etc/apt/sources.list 에 아래 추가 {{{ deb http://download.tuxfamily.org/shames/debian-lenny/desktopfx/unstable/ ./ }}} 2) 시냅틱 업데이트후 compiz-fusion-gnome, fusion-icon 패키지 설치 3) 루트 터미널에서 {{{ # nvidia-xconfig -add-argb-glx-visuals -d 24 -composite -allow-glx-with-composite }}} 4) 시스템 -> 기본 설정 -> 세션[[br]] 세션 기본 설정 대화상자의 시작 프로그램 탭에서 더하기 버튼[[br]] 시작 프로그램 더하기 대화상자[[br]] 이름:compiz-fusion[[br]] 명령:fusion-icon 5) 재부팅 6) 팁 패널 fusion-icon 마우스 오른쪽 버튼 클릭 Settings Manager실행[[br]] Viewport Switcher 체크 하면 바탕화면에서 가운데 휠 버튼 누르면 큐브회전됨 7) 원형 큐브를 원할 경우[[br]] 시냅틱에서 compiz-fusion-plugins-extra 패키지 설치[[br]] Cube Reflection and Deformation 체그 === cairo dock === 그놈 메뉴 -> 시스템 도구 -> 설정 편집기(gconf-editor)에서 아래 체크 {{{ /apps/metacity/general/compositing_manager }}} testing(squeeze)는 공식 저장소에 있음[[br]] stable(lenny)는 아래 참고해서[[br]] https://launchpad.net/~cairo-dock-team/+archive/debian 저장소 키 추가 {{{ # apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E80D6BF5 }}} 소스리스트에 아래 추가 {{{ deb http://ppa.launchpad.net/cairo-dock-team/debian/ubuntu hardy main }}} === unstable로 만들기 === 어느 정도 testing사용에 자신감이 생긴 후 원하는 경우 unstable 버전으로 만들 수 있습니다. unstable(sid)은 따로 CD를 다운로드 받아서 설치하는 것이 아니라[[br]] 저장소 sources.list의 testing(squeeze) 부분을 unstable(sid)로 바꾸고 시냅틱에서[[br]] "모두 업그레이드 표시" 버튼을 누르고 적용 버튼을 눌러서 업그레이드 시키면 됩니다.[[br]] sources.list를 아래처럼 바꾸세요. {{{ deb http://ftp.us.debian.org/debian/ unstable contrib non-free main deb-src http://ftp.us.debian.org/debian/ unstable contrib non-free main }}} or {{{ deb http://ftp.us.debian.org/debian/ sid contrib non-free main deb-src http://ftp.us.debian.org/debian/ sid contrib non-free main }}} === 삼바 설정 === 삼바 설정은 리눅스의 삼바 공유 폴더로 접근 할 때 자신의 계정명은 같은데 비밀번호는 자신의 리눅스 계정과 삼바 계정이 다를 수 있다라고 생각하면 쉽습니다.[[br]] 1)시냅틱에서 samba와 사용편의를 위해 nautilus-share 패키지도 설치[[br]] 2)루트 터미널에서 {{{ # smbpasswd -a 자신의 계정 삼바용 비밀번호 입력 (리눅스 비밀번호와 같게 해도 되고 다르게 해도 됩니다.) }}} 3)테스트[[br]] 노틸러스안에서 자신의 계정안에 있는 폴더 오른쪽 버튼 누르고 공유 설정후[[br]] 다른 컴퓨터에서 접근후 자신의 계정명과 삼바용 비밀번호 입력 * Sharing Options 메뉴 아이템[[br]] "Sharing Options"는 nautilus-share 패키지를 설치하면 생기게 되는데 사용하시려면 루트 터미널에서 {{{ # usermod -a -G sambashare 자신의 계정 # groups 자신의 계정 }}} 해주시고 X재시작(ctrl+alt+backspace) 하세요.[[br]] 그룹을 추가하지 않았을 경우 아래 에러가 발생합니다. {{{ 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error 허가 거부됨 You do not have permission to create a usershare. Ask your administrator to grant you permissions to create a share. }}} "Sharing Options"의 장점은 MS윈도우처럼 공유 폴더에 손모양이 생깁니다.[[br]] 주의사항으로 권한 설정이 없는 fat32 파일 시스템이나 자기 소유가 아닌 폴더를[[br]] "Sharing Options"로 공유하면 아래 에러가 발생합니다. {{{ 'net usershare' returned error 255: net usershare add: cannot share path /폴더/경로/ as we are restricted to only sharing directories we own. Ask the administrator to add the line "usershare owner only = False" to the [global] section of the smb.conf to allow this. }}} 해결 방법은 기존의 "공유 폴더(S)..."메뉴를 사용하시거나[[br]] /etc/samba/smb.conf 파일의 {{{[global]}}} 섹션에[[br]] {{{ usershare owner only = False }}} 를 추가해 주고 {{{ # /etc/init.d/samba restart }}} 합니다. 참고:[[br]] 자기 계정에 sambashare 그룹 추가하는 GUI 방법[[br]] 그놈 메뉴: 시스템 -> 관리 -> 사용자와 그룹 그룹 관리 버튼 누르고 sambashare 선택후 속성 버튼 클릭[[br]] 그룹 구성원에서 자기 계정을 체크해주고 X재시작해줍니다. === 언어 변경 === 한국어로 설치했다가 영어나 다른 언어로 변경하고 싶을 때가 있는데[[br]] 그럴때는 루트 터미널에서 {{{ # dpkg-reconfigure locales }}} 실행 후 원하는 것을 설정후 재부팅하고[[br]] 로그인 창 나오면 오른쪽 아래 "언어" 메뉴에서 설정을 변경해주면 됩니다.[[br]] 자동로그인 기능을 사용한다면 로그아웃하면 위 "언어" 메뉴가 보입니다.[[br]] 설정 바꾸고 다시 로그인 해주면 됩니다. 참고:[[br]] 영어 로케일로 로그인하면 나비 입력기가 활성화가 안되어 있는 문제 해결방법[[br]] galternatives 패키지 설치 후 gksu galternatives 로 실행해서[[br]] 왼쪽 목록에서 x-input-all_ALL 을 선택 후 오른쪽 패널에서 더하기 버튼을 눌러[[br]] /etc/X11/xinit/xinput.d/nabi (priority 0)를 추가하고 선택한 후 X재시작(ctrl+alt+backspace) 해주면 됩니다. === 폴더 표준 이름 바꾸기 === 명령창을 많이 사용하는 사람은 폴더 표준 이름이 한글로 되어 있으면 불편하기 때문에 영문으로 바꾸고 싶은 경우 {{{ $ export LANG=C; xdg-user-dirs-gtk-update }}} 다시 한글로 바꾸려면 {{{ $ echo "C" > ~/.config/user-dirs.locale $ export LANG=ko_KR.utf8; xdg-user-dirs-gtk-update }}} === 파일명 대소문자 구분 문제 === 노틸러스를 실행해 보면 알파벳 대문자로 시작하는 파일들이 앞에 몰려있고 그 다음 소문자로 시작하는 파일들이 있게 되는데 이것이 싫으신 분은[[br]] en_US.UTF-8 로케일 설치하고[[br]] /etc/profile 에 아래 추가해줌[[br]] (루트 권한이 필요하기 때문에 루트 노틸러스 사용) {{{ export LC_COLLATE="en_US.UTF-8" }}} 참고:[[br]] 이렇게 하면 대소문자 구분 문제가 없는 대신 한글 정렬에 문제 생김 === 입력기 변경하기 === 한글과 영어만 입력하신다면 기본 설치되는 나비(nabi)입력기를 사용하시면 되지만[[br]] 다국어를 입력하셔야 되면 scim을 설치하시는 것이 편리합니다. ==== SCIM 설치 방법 ==== 1)scim-hangul,scim-tables-ko,galternatives(입력기 변경을 편하게 하기 위해) 패키지 설치 2)루트 노틸러스 만들듯이 gksu galternatives 를 패널에 만들고 실행후 xinput 부분 SCIM으로 변경 3)기본 한/영 전환 키 변경[[br]] 기본으로 Shift + space, 혹은 한/영 키로 변경이 되지 않기 때문에 설정을 변경합니다.[[br]] SCIM 설정--> 프론트엔드 --> 전체 설정 --> 전환키 : Hangul or Shift + space 키로 변경해줍니다. 참고:[[br]] * 우분투 8.04 설치후 SCIM 한글입력 문제[[br]] http://kldp.org/node/98658 * scim vs nabi[[br]] http://kldp.org/node/41800#comment-145694 * scim에서 capslock이 켜져있으면 한/영 전환이 안 되는 문제가 있을 수 있습니다. * uim(저장소에 있음)이란 것도 있습니다. ==== ibus에서 nabi로 바꾸기 ==== {*} '''squeeze beta2'''[[br]] 루트 노틸러스로 /usr/share/im-config/data 에 21_nabi.dsc, 21_nabi.im 파일을 만듦[[br]] 21_nabi.dsc {{{ IM_CONFIG_DSC="Korean X Input Method" IM_CONFIG_KEY="/usr/bin/nabi" IM_CONFIG_DEP="Required: nabi" }}} 21_nabi.im {{{ # start nabi # vim: set sts=4 expandtab: # start nabi /usr/bin/nabi & # set variables for the plain XIM XMODIFIERS=@im=nabi GTK_IM_MODULE=xim QT_IM_MODULE=xim }}} 루트 터미널에서 im-config 실행해서 nabi로 입력기 변경 후 X재시작 === ctrl caps 바꾸기 === /etc/X11/xorg.conf 에 {{{ Option "XkbOptions" "ctrl:swapcaps" }}} 추가하고[[br]] 그놈 메뉴[[br]] 시스템 -> 기본 설정 -> 키보드[[br]] 키배치 탭에서 아래 부분의 키 배치 옵션 버튼 누르고 Ctrl 키 위치 아이템에서 Ctrl과 {{{C}}}apsLock 뒤바꾸기 선택 이렇게 그놈 키보드 설정도 수정해줌[[br]] ({{{RC}}}1에서는 둘다 설정해야 led가 이상작동하는 것이 방지됨) === 우분투처럼 시작할때 splash보기 === startupmanager,splashy 패키지 설치 uspalsh와 splashy가 있는데 splashy 더 좋은 듯[[br]] startupmanager 패키지 설명에 "Currently only Usplash" 이라고 나왔지만 splashy도 잘됨 startupmanager에서 splash 설정 한번 하고 재부팅후에 preview 정상 작동함 === flash player 바꾸기 === 기본 flash player가 swfdec-mozilla 인데 adobe 것으로 바꿀려면 http://www.debian-multimedia.org/ 참고해서 저장소 추가후 업데이트하고 swfdec-mozilla 삭제하고 flashplugin-nonfree 설치해주면 됩니다.[[br]] {o} '''lenny''' {{{ # apt-get -y remove swfdec-mozilla # apt-get -y install flashplayer-mozilla }}} {*} '''squeeze beta2''' {{{ # apt-get -y remove browser-plugin-gnash # apt-get -y install flashplayer-mozilla }}} 저장소 추가 하는 법은 위 사이트 메인 페이지 제일 아래에 나옵니다. 참고:[[br]] * swfdec-mozilla 지울때 gnome 패키지도 같이 지워진다고 나오는데[[br]] gnome 패키지는 안에 아무것도 안들어 있는 메타 패키지입니다. 안심하고 지우셔도 됩니다. * 우리나라 일부 사이트에 들어가면 CPU 사용율 폭주하는 문제가 생긴다면 Flashblock, NoScript를 사용하세요.[[br]] https://addons.mozilla.org/ko/firefox/addon/433/ [[br]] https://addons.mozilla.org/ko/firefox/addon/722/ * 플레시가 느리다고 생각 되면 플레쉬 재생화면에서 오른쪽 버튼을 누르면 메뉴가 나오는데 버퍼링 옵션에서 버퍼용량을 1M 이상으로 바꿔사용해보세요. === 브라우저 media player 바꾸기 === 브라우저 media player가 totem-mozilla 인데 mozilla-mplayer 로 바꿀려면 {o} '''lenny''' {{{ # apt-get -y remove totem-mozilla # apt-get -y install mozilla-mplayer }}} {*} '''squeeze beta2''' {{{ # apt-get -y remove totem-mozilla # apt-get -y install gecko-mediaplayer }}} === Iceweasel(firefox) 최신 버전 설치 === 아래 사이트를 참고해서[[br]] http://mozilla.debian.net/ 저장소를 추가하고 {{{ deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0 }}} 저장소 키를 등록해 줍니다. {{{ # wget http://mozilla.debian.net/archive.asc -O- | apt-key add - }}} 그리고 iceweasel 를 설치합니다. {{{ # apt-get update # apt-get -y install iceweasel }}} === 구글 크롬 브라우저 설치 === 아래 사이트를 참고해서[[br]] http://www.google.com/linuxrepositories/apt.html 저장소를 추가하고 {{{ deb http://dl.google.com/linux/deb/ stable main non-free }}} 저장소 키를 등록해 줍니다. {{{ # wget https://dl-ssl.google.com/linux/linux_signing_key.pub -O- | apt-key add - }}} 그리고 google-chrome-unstable 를 설치합니다.[[br]] (google-chrome-beta 는 확장 프로그램 설치시 여러 문제가 있음) {{{ # apt-get update # apt-get -y install google-chrome-unstable }}} 확장 프로그램(파이어 폭스의 부가 기능)은 아래 사이트 참고[[br]] (툴바 오른쪽 끝 버튼 누르면 나오는 메뉴에서 확장 프로그램을 선택하면 됩니다.)[[br]] https://chrome.google.com/extensions === 오페라 브라우저 설치 === 아래 사이트를 참고해서[[br]] http://deb.opera.com/ 저장소를 추가하고 (lenny 기준) {{{ deb http://deb.opera.com/opera/ lenny non-free }}} 저장소 키를 등록해 줍니다. {{{ # wget http://deb.opera.com/archive.key -O- | apt-key add - }}} 그리고 opera 를 설치합니다. {{{ # apt-get update # apt-get -y install opera }}} == 팁 == === Alt + F2 === MS윈도우의 시작 메뉴에 있는 "실행..."과 비슷한 역할을 합니다. === 기본 개발도구 설치 === 최신 프로그램같은 경우 저장소에 없을 수 있는데 그럴 경우 컴파일 설치를 해야 합니다.[[br]] 보통 저장소에서 build-essential 패키지를 설치하면 컴파일 설치에 필요한 gcc, make, patch등 모든 기본 개발툴들이 설치 됩니다. {{{ # apt-get install build-essential 다음 패키지를 더 설치할 것입니다: binutils bzip2 cpp cpp-4.4 dpkg-dev fakeroot g++ g++-4.4 gcc gcc-4.4 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libc-dev-bin libc6-dev libdpkg-perl libgomp1 libmpfr4 libstdc++6-4.4-dev libtimedate-perl linux-libc-dev make manpages-dev patch }}} === rm 명령 주의사항 === rm 명령으로 삭제하면 복구 불가능하니 주의하세요.[[br]] debugfs로 복구가 가능하다는 이야기도 있지만 ext3 파일시스템에서 저는 모두 실패하였습니다.[[br]] 혹 안 지워지는 파일때문이라면 위에서 만든 루트 노틸러스를 사용해서 휴지통에 버리세요.[[br]] 예를 들어 자신 계정의 바탕화면에 안 지워지는 파일이 있다면 루트 노틸러스를 실행해서[[br]] /home/자신의 계정/Desktop 에 들어가서 삭제하시면 됩니다. 참고:[[br]] ext3grep - ext3 복구를 쉽게[[br]] http://kldp.org/node/103288 === 자바&eclipse 설정 === http://kldp.org/node/102887#comment-476569 [[br]] http://kldp.org/node/102887#comment-476449 [[br]] http://kldp.org/node/116040#comment-531587 === 동영상 재생관련 === 동영상 코덱때문에 재생이 안 되는 것이 있다면 위 [http://wiki.kldp.org/wiki.php/DebianInstallationQuickNote#s-3.9 flash player 바꾸기]에서 보신 것처럼[[br]] debian-multimedia 저장소 추가해주고 w32codecs 패키지 설치하면 거의 대부분 재생이 잘 됩니다.[[br]] 동영상 재생기는 smplayer가 대세인듯 싶습니다. === smplayer 스크린 세이버 문제 === mplayer 버전이 올라가면서 smplayer 환경 설정에서 화면 보호기 비활성화를 설정해도[[br]] 작동이 제대로 안 되는데 아래 파일에 ~/.mplayer/config (~/.smplayer 와 혼동하지 마세요.) {{{ heartbeat-cmd="gnome-screensaver-command -p &" }}} 를 추가하세요. 출처 : http://smplayer.wiki.sourceforge.net/FAQ === emacs 23(snap-shot) 설치 === 아래 문서 참고하세요.[[br]] http://wiki.kldp.org/wiki.php/EmacsTinyTips#s-1.2 === 저장소 패키지 문제 === lenny가 testing에서 stable이 되면서 시스템을 업그레이드를 하면[[br]] 일부 패키지가 없어서 이상하게 되는 경우가 있는데 sources.list에 {{{ deb http://ftp.us.debian.org/debian/ etch contrib non-free main deb-src http://ftp.us.debian.org/debian/ etch contrib non-free main }}} 처럼 etch 저장소를 추가해 보세요.[[br]] 저같은 경우 etch 저장소를 추가 안했을때 libgpmg1,python-mode 패키지 설치에 약간 문제가 있었습니다. etch 저장소를 추가해도 기본 설정상태에서는 최신 패키지(lenny)가 설치되고[[br]] 아주 일부 lenny 저장소에 없는 패키지만 사용하게 되므로 아무런 해가 없습니다. === lenyy backports 저장소 추가 === http://backports.org/ 저장소를 추가하고 {{{ deb http://www.backports.org/debian lenny-backports main contrib non-free }}} 저장소 키를 등록해 줍니다. {{{ # wget http://backports.org/debian/archive.key -O- | apt-key add - }}} 저장소 업데이트 {{{ # apt-get update }}} === lenny(stable)을 사용하지만 testing, unstable 에 있는 패키지 설치하기(Apt Pinning) === stable에는 없지만 testing, unstable 저장소에 있는 패키지를 설치하고 싶을 경우[[br]] Apt Pinning 를 이용하는 방법이 있습니다. * Apt Pinning - Debian Wiki http://wiki.debian.org/AptPreferences * debian 에 최신 버젼의 package 설치하기 http://aproxacs.springnote.com/pages/482071 참고: 의존성 문제가 생길 수 있으므로 주의해서 사용하세요. === Iceweasel 다운로드 완료 알림창 제거하기 === 리눅스에서는 오른쪽 아래에 작업 공간을 바꾸는 애플릿이 있기 때문에[[br]] Iceweasel 다운로드 완료 알림창이 나오면 약간 불편한데 그럴 경우 제거가 가능합니다.[[br]] Iceweasel 주소 표시줄에 about:config를 입력하고 "고급 환경 설정 기능" 페이지가 나오면[[br]] "고급 기능 사용 동의" 버튼을 누르고 들어가서 필터에 showAlertOnComplete 를 입력합니다.[[br]] browser.download.manager.showAlertOnComplete 를 더블 클릭해서 false로 바꿉니다. 그리고 종료합니다. === Iceweasel 브라우저에 Firefox 플러그인 깔기 === Iceweasel은 사실 FireFox이다. 하지만 깔리지 않는 FireFox 플러그인이 있다. 대표적인것이 Google ToolBar이다. 플러그인을 깔려면 about:config 을 URL입력창에 넣고 {{{ general.useragent.extra.firefox }}} 목록을 찾아 {{{ Iceweasel 글자를 Firefox (대소문자를 정확히 입력한다.)로 바꾼다. }}} 로 바꾼다음 FireFox플러그인을 깔면된다. === 바탕화면에 마운트 볼륨 생기는 현상 제거 === * 프로그램 --> 시스템 --> 설정 편집기 실행 * apps/nautilus/desktop/valumes_visible 체크된것 제거. 참고:[[br]] 이동식 디스크도 안 보여져서 볼륨 마운트 해제를 못하는 경우가 생깁니다.[[br]] 아래를 참고해서 설정하세요.[[br]] (리눅스에서는 sync 옵션이 없을 경우 볼륨 마운트 해제가 매우 중요합니다.) Hardy 8.04 튜닝 - 바탕화면의 하드디스크 볼륨 정리하기[[br]] http://www.ubuntu.or.kr/viewtopic.php?p=1255 === 플로피 디스크 주의사항 === 리눅스에서는 플로피 디스크에 파일을 복사하고 나서 마운트를 해제해야[[br]] 그때서야 디스크에 실제로 복사를 합니다.[[br]] 이 방식이 싫고 MS윈도우 방식을 원하시는 분은[[br]] /etc/fstab 파일의 floppy 옵션에 "sync"를 추가하세요. === 저장소 목록 === /etc/apt/source.list {{{ # debian 공식 미러 한국 사이트 deb ftp://ftp.kr.debian.org/debian stable main contrib non-free deb-src ftp://ftp.kr.debian.org/debian stable main contrib non-free # 다음 공식미러 사이트 deb http://ftp.daum.net/debian stable main contrib non-free deb-src http://ftp.daum.net/debian stable main contrib non-free # NeoWiz 한국 전용 deb ftp://ftp.neowiz.com/debian stable main contrib non-free deb-src ftp://ftp.neowiz.com/debian stable main contrib non-free }}} == 마무리 == 클론질라 같은 것으로 백업 해두고 시스템이 이상해지면 복원하면 되므로[[br]] 마음껏 여러 실험을 해보는 것도 한 방법입니다.[[br]] http://www.clonezilla.org/ (!) [wiki:primewizard] - 2008[[br]] == 자유 게시판 == [[Comment]]